question about ImageMagick-libs dependency

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Locked
phliKtid
Posts: 1
Joined: 2013-04-02T23:11:40-07:00
Authentication code: 6789

question about ImageMagick-libs dependency

Post by phliKtid »

i had need to update ImageMagick outside of the normal yum repo, so i decided to get the latest rpm
files directly from the site. after adding quite a few rpms via yum for dependencies (that the old
ImageMagick version in the normal yum repo didn't need), i got the base ImageMagick 6.8.4-6 rpm
to install. (i am on centos 5.9, for what it's worth.)

but i also needed ImageMagick-devel (for Magick-config). when i tried to install it, i got a failed
dependency for ImageMagick-libs:

# rpm -Uvh ImageMagick-devel-6.8.4-6.x86_64.rpm
error: Failed dependencies:
ImageMagick-libs = 6.8.4-6 is needed by ImageMagick-devel-6.8.4-6.x86_64

that would've be fine, except i could find no 6.8.4-6 version of an ImageMagick-libs rpm. nor any version of
an ImageMagick-libs file on the ImageMagick website itself. from looking at the contents of the -libs files
of older versions on other repos, it appeared the base ImageMagick rpm installs both binaries and library files.
so i went ahead and used --nodeps to install -devel and ignore the -libs dependency, which seemed to work.

i'd like to know if that's acceptable or if i'm really missing some stuff and things will go horribly awry
very shortly. : )

thanks!

Locked