CMYK separation problem - old bug?

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Locked
pipe
Posts: 28
Joined: 2013-04-09T08:32:37-07:00
Authentication code: 6789

CMYK separation problem - old bug?

Post by pipe »

I ran in to a problem when trying to separate CMYK channels, I'm not 100% sure it's actually a bug, but the behaviour is off.

It has been mentioned about a year ago by Anthony: viewtopic.php?f=1&t=20729#p83381

The main issue is this:
convert rose: -colorspace CMYK -separate +append roses.png
The K-channel shows up, well.. not very black, rater very much like a rainbow. :) If it is not a bug, how do I prevent it? That is, I want the black channel actually black, not in color.

Additionally, I found a difference when previewing the images with x: and show:. The latter seems pretty broken but works fine in RGB. I don't know what the difference is between show: and x:. I made a visual summary:
Image
pipe@spacelab:~$ convert --version
Version: ImageMagick 6.8.5-5 2013-05-03 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2013 ImageMagick Studio LLC
Features: DPC OpenCL OpenMP
Delegates: bzlib djvu fftw fontconfig freetype jbig jng jp2 jpeg lcms lqr lzma openexr pango png ps rsvg tiff x xml zlib

snibgo
Posts: 13034
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: CMYK separation problem - old bug?

Post by snibgo »

Confirmed for 6.8.5-0 on Windows. Eek. Previous versions, eg v6.8.4-6, made K monochrome. It seems to be a recent bug.
snibgo's IM pages: im.snibgo.com

User avatar
magick
Site Admin
Posts: 11254
Joined: 2003-05-31T11:32:55-07:00

Re: CMYK separation problem - old bug?

Post by magick »

We can reproduce the problem you posted and have a patch in ImageMagick 6.8.5-5 Beta available by sometime tomorrow. Thanks.

Locked