[RESOLVED] possible bug -level IM 6.8.5.8 beta Q16 Mac OSX

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
fmw42
Posts: 25945
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

[RESOLVED] possible bug -level IM 6.8.5.8 beta Q16 Mac OSX

Post by fmw42 »

Some of my scripts are failing.

It would appear that -level is not functioning properly starting with IM 6.8.5.5

Input:
Image

IM 6.8.1.9 works fine
im6819 convert zelda.jpg -level 0%,90.7423%,2.15993 zelda_level_6819.png
Image

IM 6.8.5.4 works fine
im6854 convert zelda.jpg -level 0%,90.7423%,2.15993 zelda_level_6854.png
Image

IM 6.8.5.4 fails
im6854 convert zelda.jpg -level 0%,90.7423%,2.15993 zelda_level_6855.png
Image

IM 6.8.5.8 beta fails
imb convert zelda.jpg -level 0%,90.7423%,2.15993 zelda_level_6858b.png
Image


P.S. It appears that -gamma with the same gamma value as above works fine.
Last edited by fmw42 on 2013-05-25T18:46:48-07:00, edited 1 time in total.

User avatar
magick
Site Admin
Posts: 11127
Joined: 2003-05-31T11:32:55-07:00

Re: possible bug -level IM 6.8.5.8 beta Q16 Mac OSX Snow Leo

Post by magick »

We can reproduce the problem you posted and have a patch in ImageMagick 6.8.5-8 Beta available by sometime tomorrow. Thanks.

User avatar
fmw42
Posts: 25945
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: possible bug -level IM 6.8.5.8 beta Q16 Mac OSX Snow Leo

Post by fmw42 »

Thanks. It is working fine in IM 6.8.5.8 Q16

Post Reply