you still break ABI

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Locked
broucaries
Posts: 467
Joined: 2008-12-21T11:51:10-07:00

you still break ABI

Post by broucaries »

Hi,

you have still broke ABI by removing two symbols of module by removing:
#MISSING: 8:6.8.8.9-1# InitializeModuleList@Base 8:6.8.8.2
#MISSING: 8:6.8.8.9-1# LoadMimeLists@Base 8:6.8.8.2
#MISSING: 8:6.8.8.9-1# RelinquishCommandQueue@Base 8:6.8.8.2

I suppose it does not need a so bump (I am a little bit tired of it) because it is only internal abi and does not need to be call.

If you think you need a so bump, please ask me before I could use the version script in order to avoid it and be compatible.

Bastien

broucaries
Posts: 467
Joined: 2008-12-21T11:51:10-07:00

Re: you still break ABI

Post by broucaries »

Exactly I have added to internal ABI as optional symbols. It means that they are not called by other library outside imagemagick source package.

broucaries
Posts: 467
Joined: 2008-12-21T11:51:10-07:00

Re: you still break ABI

Post by broucaries »

Could you also check your private message by mail?

Bastien

User avatar
magick
Site Admin
Posts: 11254
Joined: 2003-05-31T11:32:55-07:00

Re: you still break ABI

Post by magick »

We've been relying on http://upstream-tracker.org/versions/imagemagick.html to alert us to possible ABI breaks. Unfortunately it did not alert us to these missing symbols. The missing methods are internal methods. However, for the 6.8.8-10 release later this week, we'll deprecate these methods and place them in magick/deprecate.c. Thanks for alerting us to this issue.

ImageMagick version 7 declares these internal methods as private, something we can't do with version 6 for if we did, it would break the ABI.

Locked