OS specific text clipping bug

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Locked
GarbageSauce
Posts: 23
Joined: 2016-12-08T19:43:17-07:00
Authentication code: 1151

OS specific text clipping bug

Post by GarbageSauce »

Okay so this command here

Code: Select all

magick -background none -fill #000000 -font H:\python27\fonts\BW-penn.ttf -size x90 -gravity center label:"GO TIGERS!" asdf.png
Renders incorrectly as the 'G' at the beginning of the image is cut off a bit. I posted this as a question a while ago. Here is that forum. The original post on that forum includes a download link for that font I am required to use.

https://www.imagemagick.org/discourse-s ... =1&t=31017

Here is what I, including the awesome members of this community, have narrowed down. The issue is specific to the font I am using (although I only tried using like 5 others so I could be wrong). I have tried all forms of escaping the exclamation point and nothing worked. The problem is specific to the OS. The issue manifests in Windows 10 Pro but not in Linux. I don't think that the issue is specific to the variant of ImageMagick as both the 'Win64 dynamic at 16 bits-per-pixel component' and 'Win64 static at 16 bits-per-pixel component' both manifest the issue.

I am using the newest version of ImageMagick on Windows. In Linux, I opened the terminal and typed in sudo apt-get install imagemagick. I'm guessing that command downloads and installs the newest version (I am not too familiar with Linux).

In case you are wondering what Linux distro I am using, I am not. I simply installed the 'Windows subsystem for Linux' package from within Windows and that allows me to use bash from within command prompt.

User avatar
magick
Site Admin
Posts: 11254
Joined: 2003-05-31T11:32:55-07:00

Re: OS specific text clipping bug

Post by magick »

Thanks for the problem report. We can reproduce it and will have a patch to fix it in GIT master branch @ https://github.com/ImageMagick/ImageMagick later today. The patch will be available in the beta releases of ImageMagick @ http://www.imagemagick.org/download/beta/ by sometime tomorrow.

Locked