possible bug -layers merge IM 7.0.4.5 Q16 Mac OSX

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
fmw42
Posts: 25982
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

possible bug -layers merge IM 7.0.4.5 Q16 Mac OSX

Post by fmw42 »

It seems that -layers merge is causing a difference in creating drop shadow in IM 7.0.4.5 Q16 non-hdri compared to IM 6.9.7.5 Q16 non-hdri. The result from IM 7 has partial transparency in the main part of the image (as opposed to the shadow area) and has transparency on the top and left side of the output.

If I save the 2 images from the -shadow command and do a compare, the result is 0. So this leads me to believe it is a layer merge issue.

Input:
Image


IM 7:

Code: Select all

magick sample.png \
\( +clone -background black -shadow 80x3+5+5 \) \
+swap -background none -layers merge +repage sample_result7.png
Image

IM 6:

Code: Select all

convert sample.png \
\( +clone -background black -shadow 80x3+5+5 \) \
+swap -background none -layers merge +repage sample_result6.png
Image


Animation showing difference:
Image

User avatar
magick
Site Admin
Posts: 11133
Joined: 2003-05-31T11:32:55-07:00

Re: possible bug -layers merge IM 7.0.4.5 Q16 Mac OSX

Post by magick »

Thanks for the problem report. We can reproduce it and will have a patch to fix it in GIT master branch @ https://github.com/ImageMagick/ImageMagick later today. The patch will be available in the beta releases of ImageMagick @ http://www.imagemagick.org/download/beta/ by sometime tomorrow.

Post Reply