[resolved] possible bug gif histogram

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
fmw42
Posts: 22232
Joined: 2007-07-02T17:14:51-07:00
Location: Sunnyvale, California, USA

[resolved] possible bug gif histogram

Post by fmw42 » 2017-05-11T15:18:47-07:00

IM 6.9.8.4 Q16 Mac OSX Sierra.

Input:
Image

Using this command and saving as PNG works fine:

Code: Select all

convert x5hWF.png -negate -colorspace HSV -channel red -separate +channel -define histogram:unique-colors=false histogram:with_hist.png
Image


But saving as GIF, creates an file that is not openable, i.e. corrupt

Code: Select all

convert x5hWF.png -negate -colorspace HSV -channel red -separate +channel -define histogram:unique-colors=false histogram:with_hist.gif
Image

It also fails the same way in IM 7.0.5.5 Q16

User avatar
magick
Site Admin
Posts: 10698
Joined: 2003-05-31T11:32:55-07:00

Re: possible bug gif histogram

Post by magick » 2017-05-12T07:35:26-07:00

Thanks for the problem report. We can reproduce it and will have a patch to fix it in GIT master branch @ https://github.com/ImageMagick/ImageMagick later today. The patch will be available in the beta releases of ImageMagick @ http://www.imagemagick.org/download/beta/ by sometime tomorrow.

User avatar
fmw42
Posts: 22232
Joined: 2007-07-02T17:14:51-07:00
Location: Sunnyvale, California, USA

Re: possible bug gif histogram

Post by fmw42 » 2017-05-13T12:20:42-07:00

Thanks. This now works in the latest release today (6.9.8.5)

Post Reply