When specified relative or absolute path, identify or convert report error.

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
246246
Posts: 188
Joined: 2015-07-06T07:38:22-07:00
Authentication code: 1151

When specified relative or absolute path, identify or convert report error.

Post by 246246 » 2019-05-01T02:04:54-07:00

I recently do not use version 6, but I've got really confused with this behavior.
I got v6.9.9-40 from macport for my macOS Mojave 10.14.4.

Code: Select all

$ identify -version
Version: ImageMagick 6.9.9-40 Q16 x86_64 2018-11-24 http://www.imagemagick.org
Copyright: © 1999-2018 ImageMagick Studio LLC
License: http://www.imagemagick.org/script/license.php
Features: Cipher DPC Modules 
Delegates (built-in): bzlib cairo djvu fftw fontconfig freetype gslib gvc jbig jng jp2 jpeg lcms lqr ltdl lzma openexr pangocairo png ps raw rsvg tiff webp wmf x xml zlib
I downloaded file from that issue discussion viewtopic.php?f=1&t=35942 and,

Code: Select all

$ identify -quiet 10212_transparent_with_layers.tif 
10212_transparent_with_layers.tif[0] TIFF 535x1336 535x1336+0+0 8-bit CMYK 666200B 0.010u 0:00.009
10212_transparent_with_layers.tif[1] TIFF 142x246 142x246+11+230 8-bit CMYK 0.000u 0:00.000
10212_transparent_with_layers.tif[2] TIFF 29x213 29x213+17+240 8-bit CMYK 0.000u 0:00.000
10212_transparent_with_layers.tif[3] TIFF 37x58 37x58+54+245 8-bit CMYK 0.000u 0:00.000
Nothing is wrong. (Without -quiet it output warnings, but it is not a concern now.)
However,

Code: Select all

$ mkdir tmp
$ mv 10212_transparent_with_layers.tif tmp
$ identify -quiet tmp/10212_transparent_with_layers.tif 
tmp/10212_transparent_with_layers.tif TIFF 535x1336 535x1336+0+0 8-bit CMYK 666200B 0.000u 0:00.009
identify: improper image header `tmp/10212_transparent_with_layers.tif' @ error/psd.c/ReadPSDLayersInternal/1675.
Is it happen only to me, or limited to this slightly older version?

PS version 7.0.8-42 comes from brew works sane, both using magick identify command and identify command (for compatibility).

246246
Posts: 188
Joined: 2015-07-06T07:38:22-07:00
Authentication code: 1151

Re: When specified relative or absolute path, identify or convert report error.

Post by 246246 » 2019-05-01T06:48:09-07:00

OK, I checked it with 6.9.10-42 comes from Homebrew:

Code: Select all

/usr/local/opt/imagemagick@6/bin/identify -version
Version: ImageMagick 6.9.10-42 Q16 x86_64 2019-04-26 https://imagemagick.org
Copyright: © 1999-2019 ImageMagick Studio LLC
License: https://imagemagick.org/script/license.php
Features: Cipher DPC Modules 
Delegates (built-in): bzlib freetype jng jp2 jpeg lcms ltdl lzma png tiff webp xml zlib

Code: Select all

/usr/local/opt/imagemagick@6/bin/identify -quiet tmp6/10212_transparent_with_layers.tif 
tmp6/10212_transparent_with_layers.tif[0] TIFF 535x1336 535x1336+0+0 8-bit CMYK 666200B 0.000u 0:00.006
tmp6/10212_transparent_with_layers.tif[1] TIFF 142x246 142x246+11+230 8-bit CMYK 666200B 0.000u 0:00.000
tmp6/10212_transparent_with_layers.tif[2] TIFF 29x213 29x213+17+240 8-bit CMYK 666200B 0.000u 0:00.000
tmp6/10212_transparent_with_layers.tif[3] TIFF 37x58 37x58+54+245 8-bit CMYK 666200B 0.000u 0:00.000
So no problem with the recent one.

Post Reply