Page 1 of 1

magick.exe 7.0.9 -monochrome does not work

Posted: 2019-12-04T00:22:00-07:00
by cwong
Platform: Windows 10

I use magick.exe to convert image files to black and white.
It is ok in 7.0.8 previously.
However, in 7.0.9, the image generated is gray scale and 256 colors (I use IrfanView to view the image information).

Here is the input png image:
Image

In 7.0.8, I use the following command:

Code: Select all

"C:\Program Files\ImageMagick-7.0.8-Q16\magick.exe" convert test1.png -monochrome test1.magick.708.png
Output:
Image

In 7.0.9, I use the following command:

Code: Select all

"C:\Program Files\ImageMagick-7.0.9-Q16\magick.exe" convert test1.png -monochrome test1.magick.709.png
Output:
Image

ImageMagick version:
ImageMagick-7.0.9-7-Q16-x64-static.exe

Please advise. Thanks.

Best Regards,
Clive

Re: magick.exe 7.0.9 -monochrome does not work

Posted: 2019-12-04T10:31:59-07:00
by fmw42
I can confirm the issue on both IM 6.9.10.77 and 7.0.9.7 Q16 Mac OSX

Re: magick.exe 7.0.9 -monochrome does not work

Posted: 2019-12-04T19:44:11-07:00
by cwong
Thanks Fred for double checking.

Re: magick.exe 7.0.9 -monochrome does not work

Posted: 2019-12-04T19:46:58-07:00
by fmw42
I assume it will be fixed along with the other reported bug about a totally black result from using -monochrome.

Re: magick.exe 7.0.9 -monochrome does not work

Posted: 2019-12-05T20:57:02-07:00
by cwong
Thanks for the beta release and I have tried it.
(ImageMagick-7.0.9-8~beta20191205-Q16-x64-static.exe)

The output is black and white now.
However, the behavior for 7.0.9 is different from 7.0.8.
In 7.0.9, output images are missing some major details (which can be seen in 7.0.8 ).

The following are some examples.
For Test 3, the table borders are missing.
For Test 4, the left side text is missing.

Is it possible to resume the behavior in 7.0.8?
(or add parameter in magick.exe command line to control this so that we can get back the output behavior in 7.0.8?)

Please advise. Thank you!

Best Regards,
Clive


Test 1
Test1 Input:
Image

Test1 Output (7.0.8 ):
Image

Test1 Output (7.0.9):
Image

Test 2
Test2 Input:
Image

Test 2 Output (7.0.8 ):
Image

Test 2 Output (7.0.9):
Image

Test 3
Test 3 Input:
Image

Test 3 Output (7.0.8 ):
Image

Test 3 Output (7.0.9):
Image

Test 4
Test 4 Input:
Image

Test 4 Output (7.0.8 ):
Image

Test 4 Output (7.0.9):
Image

Re: magick.exe 7.0.9 -monochrome does not work

Posted: 2019-12-06T06:36:59-07:00
by magick
Thanks for the problem report. We can reproduce it and will have a patch to fix it in GIT master branch @ https://github.com/ImageMagick/ImageMagick later today. The patch will be available in the beta releases of ImageMagick @ http://www.imagemagick.org/download/beta/ by sometime tomorrow.

Re: magick.exe 7.0.9 -monochrome does not work

Posted: 2019-12-09T23:32:42-07:00
by cwong
I have tried ImageMagick-7.0.9-9-Q16-x64-static.exe.

The problem is fixed. Thank you so much!

Regards,
Clive