Issues with PNG conversion since 6.9 and 7.0

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Locked
SchwarzeMagie81
Posts: 2
Joined: 2020-01-24T03:07:36-07:00
Authentication code: 1152

Issues with PNG conversion since 6.9 and 7.0

Post by SchwarzeMagie81 »

Wenn I try to convert a PNG with Transparency in Version 6.8.9-Q16 all is working good and I can create TIF JPG and so on
If I try the same with 6.9.9-Q16 or 7.0.9-17-Q16-x64 Its not working and there is no result even if I try it without any parameters

convert test.png to test.tif

6.9.9 and 7.0.9

convert "E:\test.png" "test.tif"
convert.exe: eXIf: CRC error `E:\test.png' @ warning/png.c/MagickPNGWarningHandler/1748.
convert.exe: eXIf: incorrect byte-order specifier `E:\test.png' @ warning/png.c/MagickPNGWarningHandler/1748.
convert.exe: ND[AE]B: invalid chunk type `E:\test.png' @ error/png.c/MagickPNGErrorHandler/1715.
convert.exe: NoImagesDefined `test.tif' @ error/convert.c/ConvertImageCommand/3273.

-> Same is working perfect in 6.8.9-Q16

snibgo
Posts: 13034
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Issues with PNG conversion since 6.9 and 7.0

Post by snibgo »

SchwarzeMagie81 wrote:convert.exe: eXIf: CRC error `E:\test.png'
That looks like a file corruption that wasn't caught by older versions of IM.

Please post a link to test.png.
snibgo's IM pages: im.snibgo.com

SchwarzeMagie81
Posts: 2
Joined: 2020-01-24T03:07:36-07:00
Authentication code: 1152

Re: Issues with PNG conversion since 6.9 and 7.0

Post by SchwarzeMagie81 »

Hi Snibgo,

thx for the answer but I have to check if I can provide that image because of legal issues

Is there an option to ignore the changes, so the issue will be ignored again?

Thanks

snibgo
Posts: 13034
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Issues with PNG conversion since 6.9 and 7.0

Post by snibgo »

You can deinstall the new version, and reinstall the old version. But there is a risk, especially if you operate a server with user-supplied images. Such changes are often made to reduce vulnerabilities such as hackers inserting malware into "corrupt" images.
snibgo's IM pages: im.snibgo.com

Locked