Installation woes - no decode delegate...

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Locked
User avatar
magick
Site Admin
Posts: 11254
Joined: 2003-05-31T11:32:55-07:00

Post by magick »

ImageMagick determines the image type from its magic number (usually a few unique bytes in the first few thousand bytes of the image file), from its extention (e.g. image.gif), or from an explicit prefix (e.g. gif:/tmp/phpX16rjz). If it cannot determine the image type it throws an exception.

User avatar
magick
Site Admin
Posts: 11254
Joined: 2003-05-31T11:32:55-07:00

Post by magick »

Check to ensure you can run the convert command from the command-line:
  • convert logo: logo.gif
If that works, make sure the permissions are set properly. Does the bulletin board software has read and execute permissions to the ImageMagick software.

User avatar
magick
Site Admin
Posts: 11254
Joined: 2003-05-31T11:32:55-07:00

Post by magick »

Ok, your installtion did not include the JPEG and PNG delegate libraries. Type
  • identify -list format
to confirm. Install the JPEG and PNG development libraries and reconfigure, rebuild, and reinstall ImageMagick.

User avatar
magick
Site Admin
Posts: 11254
Joined: 2003-05-31T11:32:55-07:00

Post by magick »

On Linux systems you can install the JPEG and PNG development RPMS. Not sure how that's done on a FreeBSD system.

Locked