Undefined reference error while compiling 1.0.9

The MagickWand interface is a new high-level C API interface to ImageMagick core methods. We discourage the use of the core methods and encourage the use of this API instead. Post MagickWand questions, bug reports, and suggestions to this forum.
Post Reply
mrBlaQ
Posts: 17
Joined: 2008-02-05T12:19:00-07:00

Undefined reference error while compiling 1.0.9

Post by mrBlaQ » 2012-02-24T15:30:54-07:00

I get...

Code: Select all

undefined reference to `MagickSetImageEndian'


...when running 'make' on the 1.0.9 version. 1.0.8 compiles just fine using the same install steps as outlined on http://www.magickwand.org/

What might I be able to do to overcome this missing reference?

Thanks.

User avatar
magick
Site Admin
Posts: 11100
Joined: 2003-05-31T11:32:55-07:00

Re: Undefined reference error while compiling 1.0.9

Post by magick » 2012-02-24T19:12:11-07:00

You'll most likely need to upgrade your release of ImageMagick.

BilboUK
Posts: 6
Joined: 2012-02-29T10:25:55-07:00
Authentication code: 8675308

Re: Undefined reference error while compiling 1.0.9

Post by BilboUK » 2012-02-29T10:44:14-07:00

As far I am concerned MagickWandForPHP 1.0.9 is broken -> fails to compile.

I don't know which version of ImageMagick the devs compiled it against but I tried ImageMagick-6.7.5-7 as well as the allegedly "approved" version 6.3.5-9 as specified in INSTALL (which is wrong since it's < the minimum version required by the compiler!) and version 6.3.8-11

None of these worked since the method MagickSetImageEndian() simply doesn't exist in those versions of ImageMagick.

Unfortunately I can't find a way of contacting the MagickWandForPHP devs, so I guess this will go unfixed.


I reverted to MagickWandForPHP 1.0.8 and it compiles (& works) just fine with 6.7.5-7 (although the compiler reports a lot of deprecated methods and incompatible pointer type warnings).


(c.f. http://trac.imagemagick.org/changeset/6652 )

Post Reply