Posterize doesn't work...everything else does

PerlMagick is an object-oriented Perl interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning PerlMagick.
Post Reply
adityadennis

Posterize doesn't work...everything else does

Post by adityadennis »

I'm using PerlMagick in a CGI script, and for some reason Posterize does not work. I've tried other things like Crop, and they work fine. What's so unique about Posterize?

Here's my code:

Code: Select all

use Image::Magick;			
my $image = Image::Magick->new;
$img_open = $image->Read("test.png");
$img_open = $image->Posterize(levels=>'4');
$img_open = $image->Set( page=>'0x0+0+0');
$img_open = $image->Write("test2.png");
This same code works fine for me on my local machine. Any thoughts?

User avatar
magick
Site Admin
Posts: 11126
Joined: 2003-05-31T11:32:55-07:00

Re: Posterize doesn't work...everything else does

Post by magick »

Unfortunately we cannot reproduce the problem, $im->Posterize() works as expected. We're using ImageMagick 6.5.5-4, the current release.

adityadennis

Re: Posterize doesn't work...everything else does

Post by adityadennis »

magick wrote:Unfortunately we cannot reproduce the problem, $im->Posterize() works as expected. We're using ImageMagick 6.5.5-4, the current release.
I'm using the latest release too. It's really bizarre.

LobsterMan

Re: Posterize doesn't work...everything else does

Post by LobsterMan »

I am having this issue in the command line. All functions work, except posterize. Is this a known bug? I am running CentOS release 5.2 with ImageMagic 6.2.8.0-4.el5_1.1 Installed with yum

Post Reply