Installing PerlMagick on XP - recursion / stack overflow...

PerlMagick is an object-oriented Perl interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning PerlMagick.
Post Reply
Redrobes

Installing PerlMagick on XP - recursion / stack overflow...

Post by Redrobes »

Hi there, can anyone help me to install perlmagick on windows ? I have used it in the past but I cant seem to reinstall it after an HDD failure / OS reinstall. BTW I am using WinXP x64 and I normally install IM static 8bpp.

I have tried two versions of Perl 5.8 and a Perl 5.10 both from ActiveState. By default the Image::magick is not installed so I get the PPD file from http://www.bribes.org/perl/ppmdir.html and when I type

Code: Select all

ppm install http://www.bribes.org/perl/ppm/Image-Magick.ppd
it appears to install correctly. I am sure at this point it used to work flawlessly however when I run anything that has the module required in the code then I get this...

Code: Select all

Can't load 'P:/Perl/site/lib/auto/Image/Magick/Magick.dll' for module Image::Magick: load_file:Recursion too deep; the stack overflowed at P:/Perl/lib/DynaLoader.pm line 229.
I see lots of advice about installing image magick in Windows. Its said that it gets installed as part of the standard IM installation and yet I never see this. It does not appear to be a standard module on CPAN.

I have tried to download the source and compile it yet my VC complains endlessly about code problems and differing compile switches so I think I am using a different version.

Does anyone have an up to date step by step guide to installation or ideas about what to do specifically for this problem.

Thanks

Redrobes

Re: Installing PerlMagick on XP - recursion / stack overflow...

Post by Redrobes »

The issue might be resolved if I could get the installer to put in perl magick. Here is the help during the installation...

Image

and here is the panel a few clicks later...

Image

with no checkbox for installation. Any ideas ?

Redrobes

Re: Installing PerlMagick on XP - recursion / stack overflow...

Post by Redrobes »

Problem solved via this thread:

viewtopic.php?f=3&t=10450

Looking at last link:

http://pixenate.com/pixenate/docs/Insta ... tml#im_win

i.e.
For Windows x64, we recommend installing Perl 5.8.7 for x86 (not x64). This is because there are currently (as of February 2008) no ActiveState imagemagick packages for the x64 platform. We also recommend installing ImageMagick 6.3.5 for windows x64. This version of ImageMagick is available at http://sxoop.com/3rdparty. Perl 5.8.7 for Windows is available here (http://downloads.activestate.com/ActivePerl/).
I get the check box with these two specific versions and it installed correctly and runs my scripts again ok now. So I think because I was on XP x64 which is a server 2003 derivative then this issue in the installer is still present.

Thanks to guys in that thread and pixenate !
I'll be off now :)

Post Reply