load_file error with Apache

PerlMagick is an object-oriented Perl interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning PerlMagick.
Locked
Lifestyle

load_file error with Apache

Post by Lifestyle »

Hi,

i've got a Problem Using Perlmagick with my Apache Server. At first i would write down my system enviroment:

WinXP SP2 32bit
Perl 5.10.1.1007
ImageMagick-6.6.2-5-Q16-windows-dll.exe
Apache 2.2.15

Mod perl is installed as module in Apach2, but after deinstalling it the error is still the same.

While installing ImageMagick everything works fine. The demo pl skripts which are included in imagemagick are working fine, also.

The problem will show it's face wehen i'am using the use statement for PerlMagick in an cgi file, which is interpretet by Apache2.
The pache log shows the following error:

[Wed Jun 16 08:00:39 2010] [error] [client 127.0.0.1] Can't load 'C:/Perl/site/lib/auto/Image/Magick/Magick.dll' for module Image::Magick: load_file:Das angegebene Modul wurde nicht gefunden at C:/Perl/lib/DynaLoader.pm line 201.\r
[Wed Jun 16 08:00:39 2010] [error] [client 127.0.0.1] at D:/VAA/html/cgi-bin/annotate.cgi line 4\r
[Wed Jun 16 08:00:39 2010] [error] [client 127.0.0.1] Compilation failed in require at D:/VAA/html/cgi-bin/annotate.cgi line 4.\r
[Wed Jun 16 08:00:39 2010] [error] [client 127.0.0.1] BEGIN failed--compilation aborted at D:/VAA/html/cgi-bin/annotate.cgi line 4.\r

So i tried to follo the information in this thread viewtopic.php?f=7&t=15208&p=53568&hilit ... ows#p53568.
After restarting my Computer the error message is still the same, but the Apache2 doesn't even start anymore.

httpd.exe: Syntax error on line 130 of C:/Apache2/conf/httpd.conf: Cannot load C:\\Perl\\site\\lib\\auto\\Image\\Magick\\Magick.dll into server: Das angegebene Modul wurde nicht gefunden.
[Wed Jun 16 08:09:08 2010] [warn] (OS 995)Der E/A-Vorgang wurde wegen eines Threadendes oder einer Anwendungsanforderung abgebrochen. : winnt_accept: Asynchronous AcceptEx failed.

I've also installed the windows distributable.
Any ideas ?

Lifestyle

Re: load_file error with Apache

Post by Lifestyle »

oK,..., it was my fault,...

after restarting my computer, as it was described in the mentioned thread, the apache server worked fine with a linked Magick.dll,.

Locked