Exception 410: unrecognized interlace type `None' error

PerlMagick is an object-oriented Perl interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning PerlMagick.
Locked
vk_imagemagick

Exception 410: unrecognized interlace type `None' error

Post by vk_imagemagick »

Greetings,

I am seeing the following exception when attempting to process some images using ImageMagick: Exception 410: unrecognized interlace type `None' @ error/Magick.xs/SetAttribute/1605. This same code works fine on another system with the same version, so I'm attempting to pinpoint whether or not perhaps there might be some kind of installation problem, where perhaps the program is installed but the config is incorrectly set up?

ImageMagick Version:
Version: ImageMagick 6.5.9-0 2010-01-21 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2010 ImageMagick Studio LLC


OS:
Solaris 8 HW 5/03 s28s_hw2wos_06a SPARC
Copyright 2003 Sun Microsystems, Inc. All Rights Reserved.
Assembled 30 April 2003

From the logs I’m working with:
8/06/2010 14:11 DEBUG(28861): resize() Result:, Exception 410: unrecognized interlace type `None' @ error/Magick.
xs/SetAttribute/1605

Call to resize, via a script that uses PerlMagick to call ImageMagick:
$x = $image->Resize(Geometry=>$geometry."!", filter=>'Lanczos');

Via PerlMagick, I'm setting the interlace with the following:
$x = $image->Write(interlace=>'None',quality=>$quality,matte=>'False',compression=>'JPEG',filename=>"$outputfile");

Locked