Issue with PerlMagick and Apache

PerlMagick is an object-oriented Perl interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning PerlMagick.
Post Reply
hs2323
Posts: 2
Joined: 2011-08-04T06:38:31-07:00
Authentication code: 8675308

Issue with PerlMagick and Apache

Post by hs2323 » 2011-08-04T06:44:14-07:00

Hi All,

I am having an issue with PerlMagick with Apache on Snow Leopard. When I run ImageMagick from the command line it works fine. When I run ImageMagick directly from a Perl script (using Image::Magick) it runs fine. The issue comes in when I run it from a Catalyst script online through mod_perl. It throws me an error in the log "No such file or directory" when reading an image. The debug log for ImageMagick gives me GetList: UnrecognizedType 8. Any help with the issues would be appreciated

I have installed ImageMagick with PerlMagick from Macports.

User avatar
anthony
Posts: 8883
Joined: 2004-05-31T19:27:03-07:00
Authentication code: 8675308
Location: Brisbane, Australia

Re: Issue with PerlMagick and Apache

Post by anthony » 2011-08-04T20:51:48-07:00

Anything run by apache (CGI, perl, PHP, modules, etc) will probably (actually definitely) have a completely different environment to command line.

That is current working directory, PATH to commands, LD_LIBRARY_PATH to libraries, and so on.
Anthony Thyssen -- Webmaster for ImageMagick Example Pages
https://imagemagick.org/Usage/

Post Reply