6.8.4-10 Q8 bianry fails PerlMagick on windows 2003 Server

PerlMagick is an object-oriented Perl interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning PerlMagick.
Post Reply
abjones
Posts: 33
Joined: 2004-03-26T12:21:59-07:00

6.8.4-10 Q8 bianry fails PerlMagick on windows 2003 Server

Post by abjones » 2013-04-15T13:33:24-07:00

I have installed ActiveState Perl 5.16.3
I have installed ImageMagick-6.8.4-10-Q8-x86-dll.exe
Rebooted.
ImageMagick runs OK from command line, but
PerlMagick

Code: Select all

#perl
use Image::Magick;
returns
&Image::Magick::constant not defined. The required ImageMagick libraries are not installed or not installed properly.
END failed--call queue aborted.
I get the same error with ImageMagick-6.8.4-10-Q16-x86-dll.exe

Same error with ImageMagick-6.8.4-5-Q8-x86-dll.exe
but with ImageMagick-6.8.4-4-Q8-x86-dll.exe this PerlMagick error does not occurr.

dez
Posts: 15
Joined: 2013-05-02T10:52:09-07:00
Authentication code: 6789

Re: 6.8.4-10 Q8 binary fails PerlMagick on windows 2003 Serv

Post by dez » 2013-05-02T11:06:24-07:00

I'm also getting this error.

I do not have any previous versions of ImageMagick installed. I am compiling perl and ImageMagick using visual studio 2010:

Code: Select all

1) download perl source code and extract it
2) cd to perl-5.14.4\win32
3) edit makefile so that it references the correct version of visual studio and change the install path (the install path is in my %PATH%)
4) build perl using nmake, nmake test, nmake install (this works fine)
5) build ImageMagick and PerlMagick using the following:
    a) uncompress the zip file downloaded from imagemagick.org
    b) cd to VisualMagick\configure
    c) run devenv configure.sln /Upgrade
    d) run MSBuild configure.sln /property:Configuration=Release
    e) run configure.exe edit the magick-baseconfig.h change MAGICKCORE_QUANTUM_DEPTH to 8 instead of 16, accept all defaults click Next etc. until finished.
    f) cd ..
    g) run devenv VisualDynamicMT.sln /Upgrade (to convert the solution to vs2010 format)
    h) run MSBuild -ArgumentList VisualDynamicMT.sln /property:Configuration=Release (this works fine, some warnings, no errors)
    i) cd ..\contrib\win32\ATL7\ImageMagickObject
    j) run BuildImageMagickObject clean
    k) run BuildImageMagickObject release
    l) I then copy all dlls and exe files to a folder in my %PATH%
    m) cd back to base ImageMagick directory
    n) cd to PerlMagick
    o) run perl Makefile.nt
    p) run nmake
    q) run nmake test (this fails all tests with the same error: &Image::Magick::constant not defined. The required ImageMagick libraries are not installed or not installed properly.)
I am not sure what to do here, if I revert back to version 6.8.3 all this works fine. Something happened between then and now to cause this process to fail.


Thanks for any assistance.
--
Dez.

dez
Posts: 15
Joined: 2013-05-02T10:52:09-07:00
Authentication code: 6789

Re: 6.8.4-10 Q8 bianry fails PerlMagick on windows 2003 Serv

Post by dez » 2013-05-08T13:46:32-07:00

Just to update, I tested 6.8.4-2 and it did not have this issue either.

fpotvin
Posts: 2
Joined: 2013-05-09T11:07:38-07:00
Authentication code: 6789

Re: 6.8.4-10 Q8 bianry fails PerlMagick on windows 2003 Serv

Post by fpotvin » 2013-05-09T11:11:26-07:00

I had the exact same problem on Windows 7, ISS 7.5 & active perl.
Now I got image magic to load but it still fail when i try to use it Exception
420: NoDecodeDelegateForThisImageFormat `edecp/tropheequebec.com/img//300px-PNG_transparency_demonstration_2.png' @ error/constitute.c/ReadImage/550

All the delegate are available and I see all the formats in the command line with the "configure -list whatever" option.

abjones
Posts: 33
Joined: 2004-03-26T12:21:59-07:00

Re: 6.8.4-10 Q8 bianry fails PerlMagick on windows 2003 Serv

Post by abjones » 2013-06-26T07:46:03-07:00

I have not tried any other recent updates, but
My Problem is Resolved :D with
ImageMagick-6.8.6-2-Q8-x86-dll.exe

Thanks and good health!

Post Reply