Page 1 of 1

Cannot install latest version of Perlmagick

Posted: 2018-04-03T08:31:41-07:00
by bobbintb
I was using an older version of Imagemagick, 6.8.0, I believe, and the Perl command for adding a comment was not working. I could get it to work fine with just a CLI but the Perl module for that one particular function just never added a comment. I decided to uninstall and reinstall with the latest version of Imagemagick and Strawberry Perl. I was under the impression I just need to install Perl and ImageMagick but it doesn't seem to install PerlMagick even though I selected the option in the ImageMagick install.

When I run my script I get:

Code: Select all

Can't locate Image/Magick.pm in @INC
I tried to install via CPAN with:

Code: Select all

notest install Image::Magick
but it fails at the end with the following:

Code: Select all

Magick.xs:60:10 fatal error : magick/MagickCore.h: No such file or directory
I am using Strawberry Perl 5.26.1.1 and ImageMagick 7.0.7-28-Q16. This is Windows Server 2012R2.

Any ideas?

Re: Cannot install latest version of Perlmagick

Posted: 2018-04-15T10:17:27-07:00
by johnfl68
I'm not that familiar with Windows Server, but if I remember correctly, and it is similar to Linux you would need to do the following as well to add PerlMagick:

ppm install PerlMagick

Re: Cannot install latest version of Perlmagick

Posted: 2018-05-22T08:19:36-07:00
by bobbintb
Thanks, that did the trick, with a small change. I just had to point it to the ppm in the imagemagick install directory.