possible bug IM 7 CCL

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
fmw42
Posts: 23678
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

possible bug IM 7 CCL

Post by fmw42 » 2018-06-12T10:58:57-07:00

This works fine in IM 6.9.9.50 Q16 Mac OSX Sierra to make 3 of the circles transparent and leave one circle white.

Image

Code: Select all

convert image.jpg -auto-level -threshold 50% -type bilevel \
-define connected-components:remove=2,4-5 \
-define connected-components:mean-color=true \
-connected-components 4 \
image_ccl_result.png
Image

But it fails to make any circles transparent in IM 7.0.7.39

Code: Select all

magick image.jpg -auto-level -threshold 50% -type bilevel \
-define connected-components:remove=2,4-5 \
-define connected-components:mean-color=true \
-connected-components 4 \
image_ccl_result.png

Image

User avatar
magick
Site Admin
Posts: 10835
Joined: 2003-05-31T11:32:55-07:00

Re: possible bug IM 7 CCL

Post by magick » 2018-06-12T16:11:07-07:00

Thanks for the problem report. We can reproduce it and will have a patch to fix it in GIT master branch @ https://github.com/ImageMagick/ImageMagick later today. The patch will be available in the beta releases of ImageMagick @ https://www.imagemagick.org/download/beta/ by sometime tomorrow.

Post Reply