Comparing tif images in 7.0.8 version throwing error

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
nithyads
Posts: 1
Joined: 2019-03-13T23:23:12-07:00
Authentication code: 1152

Comparing tif images in 7.0.8 version throwing error

Post by nithyads » 2019-03-13T23:30:45-07:00

I am trying to compare tif iamges using 7.0.8 version. The tif images are gray in color and has white background and when i am trying to compare its throwing me error " -1.#IND<-1.#IND> "
Can you please help me with this?

If i use the comparing command with verbose, i am getting the below error.

Code: Select all

Image: C:\Temp\6892\Stellar\Position_RT.tif
  Channel distortion: MSE
    red: -1.#IND (-1.#IND)
    green: -1.#IND (-1.#IND)
    blue: -1.#IND (-1.#IND)
    all: -1.#IND (-1.#IND)
C:\Temp\6892\Stellar\Position_RT.tif=>C:\Temp\6892\St
80 640x480+0+0 32-bit sRGB 4.68795MiB 0.094u 0:00.106
:00.060

snibgo
Posts: 11571
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Comparing tif images in 7.0.8 version throwing error

Post by snibgo » 2019-03-14T06:18:55-07:00

What was your exact command?

What does "magick identify -verbose" say about the two inputs? In particular, do any of the input channels have weird values like "-1.#IND"?
snibgo's IM pages: im.snibgo.com

Post Reply