monochrome: whole output image is black

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
cwong
Posts: 6
Joined: 2019-12-03T23:46:35-07:00
Authentication code: 1152

monochrome: whole output image is black

Post by cwong » 2019-12-04T00:48:09-07:00

I use the following command to convert image to black and white:
"C:\Program Files\ImageMagick-7.0.8-Q16\magick.exe" convert input.png -monochrome output.png

Most of the output images are good.
However, I found that with the following input image, the whole output image is black.

Input image:
Image

Output image:
Image

Magick version:
7.0.8 on Windows 10

Please advise. Thanks a lot.

Best Regards,
Clive

User avatar
fmw42
Posts: 25742
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: monochrome: whole output image is black

Post by fmw42 » 2019-12-04T10:32:46-07:00


User avatar
magick
Site Admin
Posts: 11093
Joined: 2003-05-31T11:32:55-07:00

Re: monochrome: whole output image is black

Post by magick » 2019-12-04T17:02:51-07:00

Thanks for the problem report. We can reproduce it and will have a patch to fix it in GIT master branch @ https://github.com/ImageMagick/ImageMagick later today. The patch will be available in the beta releases of ImageMagick @ https://www.imagemagick.org/download/beta/ by sometime tomorrow.

cwong
Posts: 6
Joined: 2019-12-03T23:46:35-07:00
Authentication code: 1152

Re: monochrome: whole output image is black

Post by cwong » 2019-12-04T19:34:24-07:00

Thank you so much! Looking forward the beta release.

cwong
Posts: 6
Joined: 2019-12-03T23:46:35-07:00
Authentication code: 1152

Re: monochrome: whole output image is black

Post by cwong » 2019-12-05T23:03:51-07:00

Thanks for the beta release and I have tried it.
(ImageMagick-7.0.9-8~beta20191205-Q16-x64-static.exe)

Unfortunately, for the above image, the problem still persists (The whole output image is still black).
Other images do not have this problem. (relate to major color is orange... ?)

Would you please help? Thanks a lot!

Best Regards,
Clive

Post Reply