CLAHE Crashes on HDR images

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
whugemann
Posts: 310
Joined: 2011-03-28T07:11:31-07:00
Authentication code: 8675308
Location: Münster, Germany 52°N,7.6°E

CLAHE Crashes on HDR images

Post by whugemann »

OK, I have just verified that it is fixed in the current version 7.0.8-15. But I still cannot see any inluence of the clip-limit parameter. In Fiji/ImageJ its influence is quite drastic, the default value beeing 3.0. In ImageMagick, I cannot see any difference, regardless what value I supply for it. And https://www.imagemagick.org/script/comm ... .php#clahe gives no hint on what values IM expects for this parameter. Questions:
  • Is it a real or an integer value?
  • What is the range?
  • I am confused by the {+-} in front of the last two parameters. To my knowledge, most commands expect a plus a the default, as with lat, and a negative parameter tells the command something different. But how can you possibly have a negative count of histogram bins? Or what would a negative contrast threshold possibly mean?
BTW: Unless I missed something, the https://www.imagemagick.org/script/comm ... ptions.php page is hard to find via the web interface. (I landed on https://www.imagemagick.org/script/magick.php, where the option is not yet discribed.)
Wolfgang Hugemann

Post Reply