error while loading shared libraries: libMagickCore.so.4:

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
Erde

error while loading shared libraries: libMagickCore.so.4:

Post by Erde » 2010-09-14T08:59:00-07:00

So...

I've been trying to install ImageMagick on my debian box.
I configured as follows:

Code: Select all

 ./configure --enable-shared=yes --disable-static --without-perl
Didn't see any issues during configuration and make / make install.

But when I try to test the installation with: /usr/local/bin/convert logo: logo.gif
I get the following error:

Code: Select all

/usr/local/bin/convert: error while loading shared libraries: libMagickCore.so.4: cannot open shared object file: No such file or directory
When I did an locate to find the file in question, it indeed IS located at:

Code: Select all

/usr/local/lib/libMagick++.la
/usr/local/lib/libMagick++.so
/usr/local/lib/libMagick++.so.4
/usr/local/lib/libMagick++.so.4.0.0
/usr/local/lib/libMagickCore.la
/usr/local/lib/libMagickCore.so
/usr/local/lib/libMagickCore.so.4
/usr/local/lib/libMagickCore.so.4.0.0
/usr/local/lib/libMagickWand.la
/usr/local/lib/libMagickWand.so
/usr/local/lib/libMagickWand.so.4
/usr/local/lib/libMagickWand.so.4.0.0
Anyone have any insight what could be the problem?

User avatar
magick
Site Admin
Posts: 10984
Joined: 2003-05-31T11:32:55-07:00

Re: error while loading shared libraries: libMagickCore.so.4

Post by magick » 2010-09-14T09:29:01-07:00

Type
  • ldconfig /usr/local/lib

Erde

Re: error while loading shared libraries: libMagickCore.so.4

Post by Erde » 2010-09-14T10:56:21-07:00

Thank you so much! I run an imageboard and have still ways to go in UNIX administering.
That single command fixed it instantly and I spend hours trying to figure this out, haha.

Thank you again!

chlorophylle
Posts: 1
Joined: 2011-04-16T20:55:16-07:00
Authentication code: 8675308

Re: error while loading shared libraries: libMagickCore.so.4

Post by chlorophylle » 2011-04-16T21:05:03-07:00

I have the same problem.

When I type what you suggested:

ldconfig in /usr/local/lib

I have the following message (in french...):

/sbin/ldconfig.real: Ne peut créer un fichier de cache temporaire /etc/ld.so.cache~: Permission non accordée

In english it means:

/sbin/ldconfig.real:Cannot create a temporary cache file /etc/ld.so.cache : Permission not allowed

So, anyone can help me to find a solution to finish my installation correctly.

Thank you !

shekher
Posts: 1
Joined: 2011-04-27T05:33:57-07:00
Authentication code: 8675308

Re: error while loading shared libraries: libMagickCore.so.4

Post by shekher » 2011-04-27T05:37:33-07:00

Thanx a lot.

this command solve the issue .
ldconfig /usr/local/lib


I was also searching for this issue.
It working fine now.

Borracho
Posts: 1
Joined: 2011-05-23T13:49:05-07:00
Authentication code: 8675308

Re: error while loading shared libraries: libMagickCore.so.4

Post by Borracho » 2011-05-23T13:52:58-07:00

chlorophylle wrote:I have the same problem.

When I type what you suggested:

ldconfig in /usr/local/lib

I have the following message (in french...):

/sbin/ldconfig.real: Ne peut créer un fichier de cache temporaire /etc/ld.so.cache~: Permission non accordée

In english it means:

/sbin/ldconfig.real:Cannot create a temporary cache file /etc/ld.so.cache : Permission not allowed

So, anyone can help me to find a solution to finish my installation correctly.

Thank you !
Try to type :
sudo ldconfig /usr/local/lib
then enter your root password and it might work

sharifu
Posts: 5
Joined: 2012-05-01T07:53:48-07:00
Authentication code: 13

Re: error while loading shared libraries: libMagickCore.so.4

Post by sharifu » 2012-05-01T07:56:16-07:00

i have followed this and i get the following error

Code: Select all

./.convert.bin cdps5715a.tiff -resize 480x480 /opt/alfresco/tomcat/temp/Alfresco/ImageMagickContentTransformerWorker_target_4809025644968969038.png
.convert.bin: UnableToOpenConfigureFile `delegates.xml' @ configure.c/GetConfigureOptions/553.
.convert.bin: NoDecodeDelegateForThisImageFormat `cdps5715a.tiff' @ constitute.c/ReadImage/526.
.convert.bin: MissingAnImageFilename `/opt/alfresco/tomcat/temp/Alfresco/ImageMagickContentTransformerWorker_target_4809025644968969038.png' @ convert.c/ConvertImageCommand/2775.

this is bundled in with alfresco 3.4d, on centos 64bit 5.5

Post Reply